Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Examples: Monday, today, last week, Mar 26, 3/26/04

The Ultimate Smartphone Accessory

Quoted from https://www.kickstarter.com/projects/1091884999/jamblaster-the-ultimate-smartphone-accessory-for-m
The companion app or website talks to the JamBlaster over WiFi to tell it what to do. There are no physical connections needed, so you don't have to worry about compatibility problems with your current (or future) mobile devices and computers.
Yes. That feature. That core feature of how we were sold on the Kickstarter of the JamBlaster.

That is exactly and precisely what I need this thing to do, in order to justify what I paid to help bring this to fruition.

Yet, now that it's arrived, the instructions (not included, but posted later) seem to say it will only work with hard-wired Ethernet, only from Windows or Mac. If anything goes WiFi, it all goes to heck quickly. The JamTracks app for iOS has a gear icon, behind which there's nothing for connecting to the JamBlaster. There's mention of the JamBlaster in there, but it's just a link to more info - basically another advertisement for the Kickstarter. Please tell us this isn't hypeware. This is why many of us bought in.

Comments

  • Aaaahhh never mind.

    I had been scouring the how-to-set-it-up documentation, and googling (and forum searching) for info on how to set up the smartphone stuff.

    Just now, I found this:
    https://jamkazam.desk.com/customer/en/portal/articles/2669737-the-current-jamblaster-feature-set
    ...which has a PICTURE of a feature set.

    That's a very clever (i.e. underhanded) way of hiding the fact that it ain't done yet from search engine indexing.

    Now - the list of Done stuff on that picture - all great stuff. Thank you very much, even though some of those features won't apply to me personally. I can see the value of them. So kudos for getting those things done.

    It is, nevertheless, disheartening that the delivery of the physical hardware does not coincide with delivery of (even at a rough, beta level) the software which satisfies the title of the kickstarter campaign.
  • I see that this article:
    https://jamkazam.desk.com/customer/en/portal/articles/2669737-the-current-jamblaster-feature-set
    ...has still only been updated as of last December.

    As of that time, the ability to use JamBlaster as an "Ultimate Smartphone Accessory" (which is to say it works with iOS) was still remarked "We are still working on this feature."

    Is that still true? Or did that get thrown overboard? I'm not saying it'd be unwise - that might be the right call given the use-cases of a majority of your users. I just need to know.

    Here's why: the JamBlaster is ONLY useful TO ME if it works with iOS (and/or Android) as the front-end UI device. If it's not going to ever work with smartphones (or tablets), then I have two of them which have never been in a jam session available for immediate sale.

    Y'all tried to kickstart this twice. The title of the first (failed to fund) kickstarter campaign was, in fact, satisfied by the second kickstarter. The device now does what the ORIGINAL kickstarter said it would do.

    But - to the best of my knowledge, so far, the JamBlaster DOES NOT satisfy the title/blurb/vision of the second (successfully funded) campaign. And really, if what your users really needed/wanted was the first one, then all in all it's been successful, and that's cool.

    I just need to know, so I know what to do with these two boxes which haven't been powered up since early January.
  • hello Kelvin, So I follow your post here, you bought the Jamblasters to use with IOS as a front end? While I understand that's been the feature that was set, what exactly was your plan for the Jamblasters?
    You said 'the JamBlaster is ONLY useful TO ME if it works with iOS (and/or Android) as the front-end UI device'
    Sorry, but why are you limited to using IOS front end only?
    Thanks for the clarification
  • Well I overstated that to put a fine point on it. More accurately, it's only the best choice for me if it works as the kickstarter described it.

    The room(s) where I would intend to play music is not the room where my computers are, but I can get an ethernet cable there no problem.

    My brother, with whom I wish to play with some regularity, has a similar situation - his music room has a piano & guitars, but not a desk. It's not where he'd want a computer.

    So for both of us, the picture/blurb at the top of the Kickstarter is, like, "OMG, that would be AWESOME!" And it also looked like it'd be easy to explain (he's not the computer geek that I am). The entire appeal was not needing to have a computer there. Just an iPad or iPhone.

    But if that's not the way the JB is going to work, then it's probably not the way I'd choose to make JK work.
  • Well Kelvin, JB provides very low latency compared to other devices and that exactly what its for. As for Smart Phone replacing the Computer that is still in the works. No ETA though
  • Figured it may have been long enough for JK client and JB (client? server? device?) software to settle in a bit, and it was time to try it again.

    Plugged in JB. Watched the status light do a variety of things. Was several minutes before it settled into a slow green on-off-on-off cycle. Maybe it's done cooking. Just to be sure, cycled power again, and it was fewer minutes before it got to the slow green flash.

    Fired up JK on Win10. Knew there'd be an update (likely leap-frogged several versions).

    Try to connect JK to JB. Fail 3x. Reboot PC.

    PC back up, shut off all the non-essential things I can get my hands on (CrashPlan, webcam thingy, Steam, VPN, etc.). Fired up JK. This time, was able to get it to connect to the JB.

    Start solo session. Hear crackle (headphones plugged into JB). Some error message I didn't write down, about tracks or channels or inputs or something. Session doesn't start.

    Fumbled around in the JK app trying to find where I'd configure what's plugged into the two inputs of the JB. The most intuitive path to this (my opinion)...
    Click my name. Drop to JamBlaster Settings. Then click "audio" button. I'm told
    "To edit the JamBlaster audio settings, get into a session, and click the Settings link under My Tracks."
    Well, there's the problem. I can't start a session.

    Fumble some more. Find some screen (don't remember where or how, have not been able to find it again) that has something to do with adding inputs to the JB. I can make changes, and click the radio buttons for choosing that Chat will be the Music mic or the Chat mic. The "Save" button won't dismiss this window. Made several changes, changed back, changed again. Still, "Save" won't dismiss the window.

    Reboot again (and since rebooting, have not been able to find the window above which I wish I'd taken a screenshot of).

    Fumble some more. Find yet a third way to get to settings about inputs... click my name, down to "Audio Gear" which then shows two lines.
    JB Remote (active) ... then the buttons "Activate" "Configure" "Delete".
    System Default (playback only) ...then same three buttons.
    Top row, for JB Remote, I click "Configure" button. This brings up a smaller window than the one described 2 paragraphs above, this one is titled "configure tracks". I'm able to click radio buttons for "Type" under both "Input 1" and "Input 2". I'm able to turn on Phantom power for Input 2 (it's my condenser mic). Also able to use the "Instrument" drop-down to select "Saxophone" under 1 and "Voice" under 2. There's no "Save" button, but the "Close" button at the bottom of this window actually dismisses the window, so this looks promising.

    Back to home screen. Click "Sessions" panel. Then "Quick Start Solo". I hear room tone over headphones for 1 second - a brief glimmer of promise. Then it mutes again (may be correct, I dunno). A notification slides up from the bottom of the JK screen informing that "Kelvin has joined the session." It dismisses itself after a couple seconds. Then another identical notification. Then another. Then a 4th. But by now the Session window has dismissed itself and I'm back at the JK home screen. As soon as I click "Sessions" again, a pop-up says...
    "Server reported error during pairing operation. Aborting pairing process."
    Twice completely restarted JK, and reproduced all the behavior described in this paragraph.

    4th time starting JK and starting a solo session, the session stayed up. Verified that mic and "Saxophone" inputs (actually wind-synth) were audible in the headphones. Then closed the session, closed the app.

    Started JK again, hoping I could repeat success. Nope. Various flavors of nope. Seemingly random nopeness.

    This is exactly the sort of technical god-knows-what that I just can't even expect my brother to endure. Nor could I walk him through it, since it doesn't make intuitive sense to me.

    This is exactly why I desired for this to work in the veritable walled garden of a non-jail-broken iPhone/iPad such that so many of the other variables are reduced. No questions about whether my anti-malware of choice might be interfering. No questions about whether my video and/or sound cards (or built-into whatever motherboard I chose) are interfering.

    I was hoping (and somewhat expecting) that the video on the Kickstarter was how it was going to work.

    I'm going to unplug this JB, and plug in the 2nd one, let it update itself, and try this all again. Sad to say, I now 99% expect utter failure. And I expect after I've gotten myself irritated to the point of using all my favorite expletives, I will have two never-used-in-a-session JamBlasters for sale. Cheap. We'll see.
  • Unplugged 1st JB, plugged in (all the other ports first, then power of) 2nd JB. Went upstairs to make coffee... plenty of time to let the front LED settle into a slow green flash.

    Was then going to shutdown (completely) and restart JK. Would not shut down. The fact that a shutdown has always been a "but we're going to leave a little bit of it running in the background" thing has angered me since day one. Holy Hanna but I hate that. Quit means quit, for (fill-in-your-favorite)'s sake. But I digress. Anyway, I've learned the extra tricks unlike any other app I have to tell this thing to shut COMPLETELY down. But - it wouldn't.

    Reboot windows... while muttering expletives under my breath. Again shut off the extra things I usually want auto-starting, but don't want up when trying to work with "fussy" software. Now I finally get to try again. Will report back as I go.
  • The other one was 000123, and it took a few tries and power-cycles before JK could connect to JB. This one is 00076, and it connected on the first try.

    Setting the inputs worked fine (though I still haven't again found the place where I could tell it to use the Music Mic or the Chat Mic... the screen where the Save button won't dismiss the window). Anyway, so far, so good.

    Home. Sessions. Quick start solo.

    Tracks appear briefly, then disappear. Session window self-closes, back to home screen. Four notifications that "Kelvin has joined" pop up and self-close.

    Session. Quick start solo.

    Tracks appear more-briefly, then entire session window pops to home. Cursor turns to blue spinning circle, followed by the pop-up "Server reported error during pairing operation. Aborting pairing process."

    In previous attempts, I was able to get the JB to work with Mac Mini. Didn't work great, but worked. Figured after some firmware updates, and perhaps client updates, it'd work well. But my brother doesn't have (and will never have, due to unreasonable bias) a Mac. He'll be Windows. Or Android. Or iOS (wife's iPad).

    So I needed to be able to demonstrate to myself that I could get this to work with stuff HE has, which I also have. And - the simpler of those things, the better. But if it JUST WORKED REALLY SMOOTHLY with Windows, maybe, MAYBE we could compromise on the other things we had hoped for, and still make this work.

    Alas, now I do not want it to work. I just want to kill people and blow up things. You know, the only reason I have a Windows machine at all: Skyrim (and other games wherein I can kill people and blow up things).

    So, yeah, F it. I have two JBs for sale. The only thing useful for me in the entire JamKazam ecosystem is JamTracks. I'll play by myself, with JamTracks, running on my iPad. Forget playing with anyone else via JK.

    It's a great idea, but when it's so maddeningly unstable, it's impossible for me to get into the state of mind necessary for an introvert like me to push myself to be just social enough to play music with anyone else. If it was super-low-friction, when the mood strikes, I could do it. But it's not low-friction. It's a enormous struggle. And it's unfortunate, because I believe playing music with other people would be psychologically healthy for me.

    It's Sunday morning, and I feel violent. This is not cool. Take these things away from me for everyone's good, please.
  • A ways above, I described a configuration window that would not dismiss when clicking Save. Having switched over to the Mac Mini, I stumbled into it again, though it appeared when I absolutely did not expect it. And it behaved very differently than it did on Windows. I shot a video of it using my phone (I don't have, nor do I have any desire to look for record-from-screen software). It's obnoxiously blurry, but you'll be able to tell what screen it is.

  • Heh. Wow.

    I had never gotten the JB to work with JK on Windows 10 before, but today it feels like I got CLOSER to it working. Still, it didn't work (as is obvious from the above).

    Thought I would at least play a little along with a couple JamTracks, using the Mac Mini, where I had gotten the JB to work almost reasonably well, several times before.

    Doing the thing where I instruct JK to connect to the JB: easy. Just works. Like it should. Promising.

    Then, my name... Audio Gear... (on the JB Remote line) "Configure". Works just fine.

    Home screen. Sessions. Quick Start Solo. And now it ACTS JUST LIKE THE WINDOWS APP. Amazingly poorly.

    Session starts. Brief moment of hearing the mics open up. Session window closes itself *somewhere* within the FOUR times the notification slides up from the bottom informing me that "Kelvin has joined the session".

    I'm absolutely befuddled that it's not only working worse on Mac after the latest update (to the JK client AND to the JB), but it's exhibiting the exact same misbehavior as it does on the Windows machine which has never worked. I guess that means it cannot be the fault of some software on my Windows box. It cannot be because of the anti-malware I run on Windows.

    This almost makes me wish I could start the Mac Mini in Safe Mode With Networking. LOL!
  • Closest I can come (to my knowledge) on the Mac OS to a "Safe Mode With Networking" is as follows...
    Restart Mac.
    Login.
    Let it start all its (and my) usual startup stuff.
    Then in the upper-right bar, click and quit:
    Adobe Creative Cloud
    TeamViewer
    Dropbox
    Google Drive
    CrashPlan
    ...and I did NOT manually start Synergy (shares mouse-and-keyboard amongst several OSes just by rolling mouse pointer from one screen to next), which had been running during previous attempt. So now my Mac is not listening to my Windows keyboard/mouse at all.

    The ONLY thing running is the Finder, and TimeMachine. I'm sure I could shut off TimeMachine, but I can't imagine you guys have been doing that, or I would have read it in the Forums repeatedly.

    So now Mac's running about as thin as it ever does. Start JK. From my name, hit JamBlaster Settings. See the device on the network, hit "connect"... then "CONNECT" button. Even though the dialog says to, I don't need to push the button on the back of the JB. It's already connected by the time I could have. Window now says "connected to JamBlaster" and I close this window.

    Remember that thing I posted months ago about a pop-up saying
    Warning
    Invalid audio input configuration: Input channel count (16) greater than number of input channels (16)
    Yeah... so that's still going on.

    I was considering keeping just ONE of the JBs, if it would allow me to play by myself and a JamTrack, with the Mac, because it means I don't need to set up a mixer, and my office remains significantly tidier. Fewer cords and stuff.

    But - yeah - this is now as useless on Mac as it has always been on Windows. Selling both.

    Please feel free to delete this entire thread. It's helpful to noone. I'll reply on someone else's thread about JB for sale. Or if I can't find that, will post my own.
  • DON'T DELETE YET - I WANNA READ ALL OF IT FIRST!!
  • Hello Kelvin
    Sorry you had this experience. I have a JB, never had any of the issues you are seeing.
    1) Dont use Audio Config, thats ONLY for non Jamblasters
    2) Use JamBlaster Settings under the your account name
    3) You cannot test two Jamblasters. Once one is tied to your account I would think you will have
    issue with the second. Its unexpected that one user will have two Jamblasters tied to their account
    4) Once the session opens up (using the first JamBlaster) Under 'my live tracks' click 'settings' then you will see the Jamblasters tracks. Make sure you adjust the the correct input formats.
    5) Save and close
    6) In The session UI where you see the three Jamblaster tracks, make sure the chat mic speaker is not x out for muted (unless you want it muted)
    7) Load a Jamtrack (if you have not already signed up for a free one please do so)
    8) Play it back should be finr

    If this does not work for you and you want to get it working we can help. support@jamkazam.com

    Best regards
    Mark
  • 3) You cannot test two Jamblasters. Once one is tied to your account I would think you will have issue with the second. Its unexpected that one user will have two Jamblasters tied to their account
    Well... that's funny.

    I'd initially intended to open one, set it up, discover it to be awesome, and then once I'd gotten it to work with my iPhone, I could then bring the unopened one to my brother's place and start to walk him through it.

    I only opened the 2nd one once my various and plentiful struggles convinced me that the first one was probably a defective unit.

    Dang. Is there something y'all can do on your end to wipe out any link-to-my-account things so I can try to start from scratch and only link one?

    And yeah, I have around a dozen JamTracks.
  • Yes we can fix this. Please email support@jamkazam.com with the details. Please include accounts, serial numbers of the JB and which one you want removed from your account
  • edited March 2017
    Sent email to have one JB S/N detached from my account.

    Reproduced the current behavior, with butt-end of iPhone sandwiched between headphones, but apparently when shooting video, it uses a microphone by the camera lens, so you can't hear the JB headphone output go "open mic" briefly. But it does - for just a half second, as the three tracks pop into view.

    Video of this:


    Sorry about the wallpaper, hope nobody's offended by a mermaid.
  • Kevin,
    -When the session disappeared, try re-pairing with the Jamblaster before creating a session. The second time, you were creating a non-paired session. You can always check your pairing state by right-clicking on the JamKazam client icon in the systray menu and select "JamKazam Clients" The menu will show you which JB you are paired with (it will have check mark beside it in the menu). If no check mark is present you are not paired, so try repairing.
  • Peter Waker (note the missing L).

    You're right. If I re-pair between attempts to start a Quick Start Solo, it behaves the same way both times. Shows 3 tracks, I can briefly hear mic audio through headphones, and it shuts down.
  • What a difference a month makes.

    Close to striking a deal to sell one of my JamBlasters, I figured it was high time to plug stuff in and give it another try.

    I'm getting a network "you might not be able to do this" sort of pop-up, but that doesn't surprise me... I've added a VPN, but haven't added a rule to allow the DHCP server to assign the JamBlaster an IP outside of the VPN'd range. I dismissed it and moved on. Software update on the Mac, firmware update on the JB (I expected both of those were likely).

    A couple restarts later, and the two were again paired, ready to try Quick Solo session (with JamTrack) again.

    Nothing glitched.
    Not kicked out of my session.
    I could hear myself, AND the JamTrack.
    Worked perfectly!

    Now - how do I go about finding the MAC address of this JamBlaster? Can it be mathematically derived from the SerialNumber or something?
  • Now - how do I go about finding the MAC address of this JamBlaster?
    Belay that. I found in the JamBlaster Settings screen I could see what IP address it had. Looked that up in the DHCP Leases table of my firewall, and copied the MAC address from there.

    Restarted JB and JK. Sure enough, now it has the IP I've assigned it in the DHCP Server's setup. Yay! No VPN!
  • Damn! I'll never get mine going after reading all that crap!
  • Samson, please see your other post
Sign In or Register to comment.