Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Examples: Monday, today, last week, Mar 26, 3/26/04

Trying to reduce latency

A fellow bandmate and I are trying to test JK to see if it will be a viable alternative to in-person rehearsals. I play bass, he plays drums. We also have guitar, keys, vocals and horns. But we want to make sure he and I are locked in before we bring in the other members.

So far, we have everything working. I hear him, he hears me.

Total latency is right around 25-26 ms. However, he is hearing me somewhat behind him and feels a constant need to slow down.

Here are our particulars:

Me:
Computer: Dell Precision laptop, Intel i7 processor, Windows 7 Pro.

Interface: Focusrite Saffire Pro 40, firewire

Internet: Time Warner Cable, 118 Mbps download, 12 Mbps upload

Him:
Computer: Apple iMAc 2010

Interface: Presonus Firestudio Mobile, firewire,

Internet: Time Warner Cable, 100+ Mbps download, 10 Mbps upload



Jamkazam is giving us the following info:

My Processor: 0%

My interface latency: 2.9 ms (buffer size of 32, works fine no pops)

His Processor: 30%

His interface latency: 8.8 ms

Internet (both of us) : Approx 15-16 ms.

I'm guessing that the total of 25 ms is the sum of our internet latency plus his interface latency, since it's the slower of the two: 16+9=25 Is this correct?


Does anyone have any ideas on how we can get our latency down to 20 ms or below?

Both of us are connected to our wireless routers directly with cat 6 cable. We have tried bypassing the routers and going straight into the cable modems but it did not make a difference.

Is there any way to decrease his interface buffer size in Jamkazam?

We both are very enthusiastic about getting this working but we need to shave off about 5 ms or so to make it comfortable.

Thanks for your input.

Comments

  • Here is a screenshot of what I am seeing on his end.
    Latency.jpg
    400 x 623 - 59K
  • edited December 2016
    Drummers (and singers) can be particularly sensitive to latency, but the alternative may be to spend the time, effort, and gas to - break everything down & load it into the car / drive to practice / unload the car & set it all back up again - PRACTICE - then repeat everything in reverse.

    Going with practicing online is an imperfect world and it may just mean relaxing a bit if he's splitting hairs over 5ms (i.e. basically nothing @ 1/200th of a second.)

    BTW - I cut my audio interface (Scarlett 18i8 usb) latency from 11ms to 2ms by switching from direct to using it with ReaRoute through Reaper... strange, but true even though it involves an additional program.
  • Hello Scott
    The Focusrite Saphire mix control panel should be set as follows- ASIO =32 and Firewire latency = small. You have to shut down all other applications including jamkazam to make these changes. Then rerun the audio gear setup. Make sure you select Saphire ASIO for both in and out device and set to 48k. On your friends setup, open the control p[panel and set the buffer to the lowest value. This should be enough to get you to the lowest latency available for your setup. NOTE** DO NOT USE DEVICE MONITORING. What this means is mute the input channels in the Saphire and Prosonus and monitor in Jamkazam under Personal Mix (Local Audio). I suspect you will get much better results. I have a Saphire and getting anything below 30 MS should be good enough for most practice situations. I have gotten down to 12 mS with some users on the same ISP as i am and anything below 22 mS you cant hear a delay that is anything more than what you would hear in a room asssuming there are no delays in the gear (like additional plug-ins, DAW, ect)
  • Thanks for the replies Andy and Mark.

    My setup is probably as good as it can get. 2.9 ms audio latency. Processor barely even working. I'm the only one in the group using Windows. I don't think I can cut my internet ping down below 15ms unless someone has an idea for that. I just changed my internet fluid so I'm sure it isn't that. :-P

    What I'm really looking for are ways to cut the latency of the other members, all of whom are using Macs.

    Unfortunately, ReaRoute is ASIO and therefore not compatible with Mac, but interesting. I'll check it out for myself.

    Both of us have turned off direct monitoring and that certainly did help.

    Mark, when you said for my friend to "open the control panel and set the buffer to the lowest value", are you referring to a control panel in MacOS itself or a control panel within Jamkazam? Sorry, I'm not a Mac guy at all and the term "control panel" sounded like windows terminology.

    I think lowering their buffer sizes will be the key but I just don't know how to tell them how to do it. From what I have read online, on Macs, buffer size is set in the "host application". As far as I can tell, this would be Jamkazam but I am not aware of a way to set buffer size in JK.

    Thus far we haven't touched plug ins at all. Just wanting to get the latency around 20ish.

    Thanks again.
  • Usually all pro audio devices mac or windows have a control panel to configure the device. Likely your buddy has a high delay. Make sure to monitor in the software rather than outside of jamkazam
  • Right. The Presonus Firestudio Mobile has an app called Universal Control. It allows you to change the sample rate and buffer size(windows only). For Macs, the documentation says the buffer size is controlled by the "host application". In most cases, I think this would be the DAW. In this case I think the host application would be JK. So I we are looking for some other way to lower the buffer size. If anyone knows how to do this, I'm all ears!
  • Well the first thing is we need to know exactly how much latency the device is reporting. Can you mouse over the stats on your buddy while in a session and screen shot it? Then send to my attention support@jamkazam.com
  • Please see the second post. Screenshot is there
  • @ 25 mS you should be fine (assuming the screen shot is your buddy). We need to know more about how he monitors. Like does he hear his local audio delayed? Does he monitor in the JK software?
  • He is monitoring through jamkazam and has direct/zero latency monitoring turned off.

    He says there is some local delay of his drums but the main issue is that he hears me (bass) delayed behind him and this causes the desire to slow down constantly.
  • Hello Scott, please connect with your partner in a session and screen shot the statistics (mouse over the red/yellow dot next to his name and screen shot the whole stats) This will tell us whats going on in the connection and his network. Further, Interface: Presonus Firestudio Mobile, firewire, there are settings for
    buffering, you need to set this at its lowest value.

    Please provide the requested.
  • Thanks Mark.

    I provided a screenshot of his stats in the second post of this thread. It's all there.

    We haven't tried again due to holiday schedules but are going to try again tonight. It will be 4 people within a 100 mile radius. I am using Windows, the rest are using Macs.

    Each of the other 3 members have made significant improvements to their internet speeds by upgrading their service and modems, now we all are getting approximately 100 mbps down and 15 up.

    The only variable that remains is buffer size. If they could lower their buffer sizes I think we'd be golden. Mine (Windows) is fine. On a Mac, this appears to be something that the JK software must control, but apparently there is no buffer setting in JK for Mac.

    The 3 interfaces they are using are as follows: Presonus Firestudio Mobile, Presonus Firebox, Focusrite Saffire 2i4. They all report that when recording with these interfaces the DAW itself allows them to set the buffer size, not the driver software as in Windows.

    If anyone has any suggestions on how they can lower their buffer sizes I'm all ears.

    Thanks

  • Jamkazam client on MAC will attempt to use the lowest setting available. Only the Focusrite usually has a GUI/APP to make buffer changes on the mac. FYI @ 25 MS you should already be golden. So did you check the Jitter Queue on each persons stats? Please do this as a value over 2 will be a bug latency issue. I also suggest you test with each of the 3 others individually over all together. You need a sanity test to make sure exactly which users have the problem.

    best regards
    Mark
Sign In or Register to comment.