Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Examples: Monday, today, last week, Mar 26, 3/26/04

Getting your ASIO driver to pass the JamKazam jitter requirements with a 2.5ms or better frame size

I have a Behringer QX1202USB mixer that worked very well on one PC, but not the PC that I wanted it to work with. I used the Behringer driver that can be found here: http://www.behringerdownload.de/_software/BEHRINGER_2902_X64_2.8.40.zip with Windows 10. I suspect this problem is common to many other drivers and hardware platforms, not just my particular combination. The problematic PC was actually a faster machine than the one it worked OK on.

While monitoring jitter during a private test session, I intentionally invoked a "CPU stress test", expecting things to get worse as CPU utilization approached 100%. Oddly, things improved. In fact, the jitter was nearly eliminated. Obviously, increasing CPU utilization to 100% was not a good fix, so I started looking at CPU clock throttling as a potential cause.

My 3 GHz Intel CPU in this PC throttles back its core speed to 2 GHz during light activity to save power by using the clock multiplier, so I started thinking it might be that activity. I found that there was no direct correlation with the clock multiplier activity, so I started looking at power management. I found a parameter in Power Options > Processor Power Management that looked suspicious called "Minimum processor state". Windows 10 apparently defaults this parameter to 5% for the "Balanced Power" setting I was using.

Raising this parameter from 5% to above ~75% fixed the problem for me. I set it to 100% for some head room. The "Maximum processor state" was already 100% in my Balanced Power plan, but you should check that parameter too to be sure. I thought for sure this meant I would lose my CPU clock throttling feature, or at least I would see some change in operating temperatures, but I didn't. In fact, I saw no obvious change in the CPU clock behavior or temperature.

I looked briefly into what this parameter is supposed to do, but I have not found any explanation that explains why this fixes things without also making the CPU run hotter. In fact, it seems to run a little cooler now, but that might be from some minor airflow management changes I made inside the case during all my testing. I usually average less than .33 ms jitter for both input and output while using a 1 ms frame rate. I hope it works as well for you.

Note that the default settings for the "High Performance" power plan already use 100% for both the minimum and maximum processor state, so if you haven't changed the High Performance power plan settings, simply switching to the High Performance power plan from the Balanced Power plan may work as well or better. This fix might consume slightly more power than the default settings, which could be a small concern with battery powered PCs.

I plan to make video to show specifically how this was resolved and post it here in the next few days (hopefully). Until then, the attached image shows a screen shot of the parameter in question.
Advanced Power Options.jpg
312 x 340 - 17K

Comments

  • Here is a video I made to show how to change the Minimum Processor State setting under Windows 10, and how that setting affects JamKazam for me. I tried to attach the video to this post, but the upload never seemed to end, so I posted it to YouTube instead here:

    I am sorry about the video quality, as some of the visual dialog is washed-out, but you should still get the main points OK as I describe verbally what I am showing. During the video I talk about frame "rate", but I actually meant frame size.
  • Thanks Tommy. This is worth trying if you have a system that shows high jitter. @tommy what CPU do you have in your computer?
  • That particular machine has an Intel Core 2 Quad Q9650 with 8 GB ram on a Gigabyte EP45-UD3P mother board.
  • edited August 2017
    After further use, my latency claim of averaging .33 ms I/O jitter proved to be a bit optimistic. It's probably more like .45 ms average and a bit worse at night. The green ball changes to orange about 5 or 10% of the time during peak Internet hours, but I still have yet to see a red ball in my status since this change.
  • Hey Tommy, great tip! I'm wondering if you've had any luck lowering your internet jitter queue? Mine jumps around averaging around 4 to 8 ms. I'm running a Behringer UMC404HD and a windows 10, I5 processor, 8 Gig PC.
  • I have not had any complaints about my Internet jitter queue yet. I have seen the Internet jitter numbers from others' signals, but not my own. Is 4 to 8 ms what others are reporting of your signal? I don't otherwise know how you would make such a measurement, but perhaps you can explain more how you made those measurements.

    I am in the Detroit area and my connection to someone in Chicago is excellent (like we're in the same room), but my connection to someone in California can be iffy at certain times, but often is still very good and certainly good enough to have a good jam session. I presume our Internet jitter numbers vary mostly with distance and Internet bandwidth at each end. I use Comcast for my ISP (not their high bandwidth plan) and speedtest at about 90 Mbps down and 11 Mbps up, with a 10 to 20 ms local area ping.
  • The numbers I'm referring to are those you see while hovering your mouse over the 'Session Diagnostics and Stats' RYG dot of the person I'm connected to. I see Total Latency, Computer, Audio Interface, Internet. Under Internet I see Jitter Queue of 5 -7ms which when I hover over that stat the text box indicates added delay of 12 -18ms due to buffering. If I could get rid of that added delay our total latency would be in the mid 20ms vs 40ms+. Any ideas or suggestions?

    Thanks
  • Disable WIFI on your computer, put the computer power management in high performance *not default balanced. Use a high speed 3.0 USB connection if your computer has one. Reboot your computer router and modem. Try again
  • Rob, I could be wrong, and perhaps Mark can clarify, but I believe those are the stats of the person you are connected with. I am not sure there is anything you can do about their numbers being substandard without that person improving their setup, or more specifically their ISP.

    Mark, please know that simply switching to the High Performance power plan may not fix the Minimum Processor State setting. That would depend on whether anyone has adjusted the default High Performance settings to something non-default. Most people don't change those settings, but I certainly have in the past, so I suspect others might as well. Always best to look directly and the settings themselves, and not just which plan is selected.
  • Thanks Tommy and Mark for your help and suggestions. I think your right Tommy in that the numbers I mention above are in fact stats of the person I'm connected to. However, the person I'm connected to is seeing similar Internet Jitter Queue stats for me within a ms or so.

    So far I see no perceptible difference changing my setup from 'balanced' to 'high performance' even with the Min Processor state at 100%. My input/output interface jitter is normally under .5ms (Green) occasionally going above .5ms but never over 1ms. I tried the using the 3.0 USB connection and that sent my interface latency from 5.3ms to 68ms......whoa! Probably need to reset up the interface? I've tried rebooting the modem and router numerous times and not seen any perceptible improvement but you never know. I'll try disabling the wifi and see what happens.

    Thanks again!
  • If you switch USB ports you might want to reinstall the ASIO driver, then setup the Audio Gear again in JK. My ASIO driver claims to only install on the port where the ASIO H/W resides, but that has not been my experience. However, seeing such a big jump in latency makes me think something major is wrong to cause that for you.

    What is the physical distance between you and your jam-mates? I do believe that unless you're within 100 miles or so, your numbers will look bad. Best yet for me is connecting with another that has a yellow/orange dot, as most are red dots for me. Some red dots can still be quite good.

    I look forward to the first green dot connection during peak hours. I suspect that will be someone quite local to me with a similar high speed connection.
  • I'm in Tucson AZ and my Jam-mate is in San Diego CA so we're about 425 miles apart. Even though we have 40ms+ latency between us we still have relatively good sessions.
Sign In or Register to comment.